27 de noviembre de 2007
Por Percy Cabello


Mozilla ha lanzado Firefox 2.0.0.10, una actualización que soluciona tres vulnerabilidades de seguridad categorizadas como graves.


El primero de los bugs [en] podría permitir un script de ataque de entrecruzamiento de sitios (XSS), debido a un error en el manejo de JavaScript iniciado por los cambios de contenido en una ventana (window.location). El segundo [en] soluciona el publicitado agujero con el protocolo jar: que permitiría también ataques mediante script cruzando sitios. Mozilla ha ajustado las condiciones para cargar la URI del protocolo jar::

El soporte para el esquema de URI en jar: ha sido restringido para los archivos que se sirvan con una cabecera Content-Type con application/java-archive o con application/x-jar. Las aplicaciones web que requieran páginas firmadas deben asegurarse de que los archivos .jar sean servidos con este Content-Type. Los sitios que permitan que los usuarios suban archivos binarios deberían asegurarse no permitir archivos con uno de estos dos tipos de MIME.

No hay muchos detalles acerca del tercero [en], excepto que incluye corrupción de memoria.

Naturalmente se aconseja fuertemente a los usuarios que actualicen su Firefox. Puedes hacerlo yendo al menú Ayuda y Buscar actualizaciones..., o puedes esperar a la actualización automática dentro de las próximas 48 horas.

Etiquetas: ,

 
posted by FrancJP at 10:42 a. m. |


0 Comments: